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Open-source tools for PhenoCyclerTM and PhenoCycler-Fusion 
image analysis.  
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1 Introduction 
This guide introduces the basic workflow for spatial phenotyping, rare cell discovery, and calculating cell 
neighborhoods from whole slide images of ultra-high multiplexed tissue imaged by Akoya Biosciences’ 
assays and instrumentation. The basic workflow makes use of QuPath, StarDist, and CytoMap open-
source software tools and is inspired by the work of Nelson et al. at the University of Wisconsin-Madison. 
QuPath is developed by Bankhead et al. at the University of Edinburgh. It enables visualization, cell 
segmentation, and spatial phenotyping in whole slide images. StarDist is a cell segmentation routine 
developed by Schmidt et al. at the Max Planck Institute of Molecular Cell Biology and Genetics. It utilizes 
a convolutional neural network to segment cells based on their nuclear signal. CytoMap is a spatial 
analysis toolbox developed by Stoltzfus et al. at the University of Washington. It enables calculations of 
cell neighborhoods and can be used for rare cell discovery. Notably, there are many algorithms in python 
and R such as Squidpy and Seurat that can also be combined with this workflow, yet they are not covered 
in this document.  
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PhenoCycler and PhenoCycler-Fusion analysis workflow using QuPath, StarDist, and CytoMap. 
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2 Installation 
1 Download the latest and stable version of the QuPath software. Notably, the selected version 

should be compatible with version 0.30, which is the latest version as of this writing. Prior versions 
are not compatible.  

2 Install the StarDist extension by (1) opening QuPath and (2) dragging and dropping the qupath-
extension-stardist.jar file into the QuPath window.  

3 Click the gear button in the upper right-hand region of the QuPath window to access preferences 
and locate the QuPath user directory. (In this document we provide examples with the viewer 
background color set to black and appearance set to modena dark.) 

 
4 Download a folder of scripts supporting open-source tools for PhenoCycler and PhenoCycler-

Fusion image analysis (SCA). Extract the SCA folder contents. Open the SCA folder and copy six 
files CytoMap_colors_(2-6).tsv and custom colormaps.tsv. Use windows explorer to open the 
QuPath user directory specified in the preferences (see above figure, in this example, the user 
directory is C:\Users\gcarlson\QuPath\v0.3).  

5 Create a new folder called colormaps and paste the six colormap files. 
(C:\Users\gcarlson\QuPath\v0.3\colormaps\CytoMap_colors_2.tsv) You may close this window.  

6 Download the latest version of CytoMap. At the time of this writing the latest version of CytoMap 
is 1.4.21. After download, run the installer and follow the prompts.  

Note: We recommend viewing QuPath‘s documentation and introductory video tutorials 
(https://www.youtube.com/c/QuPath/playlists) to familiarize yourself with the software. Additionally, it 
may be helpful to review the CytoMap Guide.  
 

3 QuPath Analysis 
The following steps describe a general workflow for analyzing PhenoCycler and PhenoCycler-Fusion 
images. It is recommended to create a project for your images before you begin the analysis so you can 
save the analysis settings and annotations for all the images in the project to the project folder.  

3.1 Import images into QuPath 

https://github.com/qupath/qupath/releases/tag/v0.3.0
https://github.com/qupath/qupath-extension-stardist/releases
https://akoyabio-my.sharepoint.com/:f:/p/gcarlson/EoNGhaurtjhEgGvGkle3SwUBcd6Z7dtm74wIOD4iWysopw?e=dhUNLn
https://akoyabio-my.sharepoint.com/:f:/p/gcarlson/EoNGhaurtjhEgGvGkle3SwUBcd6Z7dtm74wIOD4iWysopw?e=dhUNLn
https://gitlab.com/gernerlab/cytomap/-/tree/master/StandaloneInstaller
https://qupath.readthedocs.io/en/stable/docs/tutorials/multiplex_analysis.html
https://gitlab.com/gernerlab/cytomap/-/wikis/Installation-Guide
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There are two ways to create a project (1) File → Project → Create Project or (2) choose Create Project 
from the main screen. You will be prompted to save your project in an empty folder.  

 

Next, add images.  

 

Set the image type to fluorescence and choose files to import. Select the PhenoCycler and PhenoCycler-
Fusion QPTIFF image(s) and click import.  

 

Double click an image in your list to open it in the viewer. 
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The image will open with all markers shown. Click on the brightness & contrast button (shown in the 
figure below) to bring up the markers list. Double click the channel to change the channel color. Use 
CTRL+A to select all markers. Right click and select hide channels to hide selected markers.  

  

3.2 Cell segmentation 

If there are no artifacts in your image use the square, circle, or brush annotation tools to draw on the 
image. Cells will be segmented within this annotated region. If there are artifacts in the image that you 
wish to avoid then after drawing the initial annotation hold “Alt” and annotate to remove regions of the 
image that contain artifacts.  

If you would like to use standard cell segmentation in QuPath navigate to Analyze → Cell detection → 
Cell detection. Set the pixel size for the experiment. The pixel size can be found in the image tab (see 
figure below). Set the cell segmentation parameters that work the best for cell segmentation.  
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In this tutorial we will focus on using the  StarDist cell segmentation script (provided in the SCA folder). 
To use this script, drag and drop the StarDist cell segmentation script.groovy file into the QuPath window. 
(Cell segmentation scripts are available for pixel sizes of 0.5, 0.37, 0.33, and 0.25 microns. The image 
pixel size can be found in the image tab.) When the script editor appears click Run → Run. A dialog box 
will appear asking you to select the StarDist cell segmentation file. Click OK to prompt the file chooser 
and choose stardist_cell_seg_model.pb in the SCA folder.  

 

Segmentation will begin automatically, and the top left of the Script Editor will show as "Script Editor 
(Running)". Additionally, if you try to perform other operations (other than zoom) QuPath will give you a 
warning that the script is running. Typically, the larger the annotation is the longer cell segmentation will 
take to complete.  
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The script may report warnings that nuclei have been skipped. These warnings can be ignored.  

When cell segmentation is complete you will see detections in red. You may toggle detections using the 
‘d’ key on the keyboard or by clicking the empty green shapes button. 

  

To view only the cell outlines, go to View → Cell display → Cell boundaries only. 

3.3 Spatial Phenotyping 

In this workflow we will demonstrate phenotyping with a machine learning classifier using the 
recommendations provided in the QuPath machine learning tutorial. The first step is to segment cells. To 
start the analysis, we recommend using relatively small areas for cell segmentation. This will expedite 
the workflow. These annotated areas should capture heterogeneity in cell phenotypes.  

https://qupath.readthedocs.io/en/stable/docs/tutorials/multiplex_analysis.html#create-training-images
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To train classifiers from multiple images loaded in the project, for each image of interest open the image 
and navigate to Classify → Training images → Create region annotations. Specify the region size and 
the classification as unclassified. Click create region. To move the region to a location of interest simply 
double click the annotation in the center and click and drag to the location of interest on the tissue. Repeat 
for each region of interest on each tissue. Select another image in the project list (click yes when asked 
to save) and repeat the process until all tissues of interest contain regions.  

 

Once you have created regions to capture the heterogeneity of the cells in the tissue sections navigate 
to Classify → Training images → Create training image. Once created, save the image. Segment the 
cells as described in the previous section.  

 

Training multiple classifiers on a single image can be confusing. Thus, it may be helpful to create training 
images so that each image can be used to create a single classifier. To create [duplicate] training images 
save your QuPath project, then navigate to Classify → Training images → Create duplicate channel 
training images. It is not recommended to create more than 5-10 training images [channels] at a time 
unless you are using a PhenoCycler and PhenoCycler-Fusion Processing computer. In each resultant 
image, the cell segmentation results will automatically be duplicated. Notably, if training images are used 
to train classifiers it is not recommended to segment the entire image as this will result in an overflow of 
cell segmentation data.  
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Next define phenotypes by creating classes. Since we plan to create machine learning classifiers based 
on individual markers, we can create classes based on image channels.  
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To create a class that is not listed as a channel, navigate to the annotations tab and select the miniature 
hamburger menu. Click “Add/Remove…” and add class. Double click on a class to change the class 
color. If you wish to create a classifier for a phenotype, add a new class and enter the phenotype of 
interest. In this workflow we classify on markers rather than phenotypes because classifying by markers 
provides a structured and flexible approach to phenotyping. Note that a minimum of two classes is 
required to begin phenotyping with the machine learning classifier.  

If you wish to discover novel phenotypes using the machine learning classifier then you may create a 
separate classifier for each marker. However, this approach can also result in in-accurate phenotyping. 
For example, if we assume that CD4, CD20, pan-CK, and CD8 should not be found on the same cell type 
then there is no reason to create separate classifiers and instead we can create a classifier containing 
CD4, CD8, CD20, pan-CK, and other.  

View the tissue at single cell resolution and select the point annotation/ counting tool. Click Add to create 
a new annotation. Now click on segmented cells expressing a target marker, e.g., CD4. Add points to 10-
30 cells.  
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Open the points / counting tool by clicking .  

Next set the class to the point annotation by highlighting a class and clicking Set class.  
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We recommend selecting 10-30 cells representative for each phenotype; however, we usually start 
training the classifier before all the cells are identified. Once a representative cell for each class is 
annotated, navigate to Classify → Object classification → Train object classifier.  

Specify the parameters for the classifier, an example is shown below.  

 

Click select to select features to include in the classifier. These features should include all relevant 
markers that define all phenotypes selected as classes. You may type in a marker name to search for a 
feature, but you MUST delete the filter criteria before applying the features to the classifier. Click apply 
when you have all desired features selected. Note that you may choose signal expressed in specific cell 
compartments (membrane, cytoplasm, or nucleus) to optimize classifier performance.  You may also 
specify which classes to use in the classifier by clicking select next to classes. Note that only classes that 
have been assigned to annotations will appear in the list.  



 
 
 

 

1080 O’Brien Drive. Suite A, Menlo Park, CA 94025 | 855.896.8401 | www.akoyabio.com | 100 Campus Drive, 6th Floor, Marlborough, MA 01752 

 

Click live update to see a pie chart of the selected classes. Notably, the legend for the pie chart is not 
visible when several classes are selected, but class colors can be referenced from the class list. To see 
filled in detections click the filled green shapes next to the overlay opacity slider (white arrow).  

When finished training the classifier, assign the classifier a name and save.  

To apply classifiers sequentially navigate to Classify and Load object classifier. Highlight the classifiers 
you wish to apply and click apply classifiers sequentially. 
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Once phenotyping is complete, click to show annotation measurements.  

 

In the table, double click the Num Detections column to sort by the annotation with the largest number 
of cells. This row of data contains summary information for your experiment.  

 

To visualize specific phenotypes in the image, highlight a class and select show or hide. Shortcut: 
Select class and press the space button on keyboard. 

 



 
 
 

 

1080 O’Brien Drive. Suite A, Menlo Park, CA 94025 | 855.896.8401 | www.akoyabio.com | 100 Campus Drive, 6th Floor, Marlborough, MA 01752 

3.4 Cell to cell distance in QuPath 

To calculate cell to cell distances, navigate to Analyze → Spatial analysis → Detect centroid 
distances→Click No when asked to split multi-part classifications.  

After distances are calculated you can view distances from cells to the phenotype of interest by using 
the measurement maps as shown below. Open the map by navigating to Measure → Show 
measurement maps. In the image below the Jet color map is selected and displayed as the distance to 
CD8 T-cells . By running the “phenotyping view.groovy” script in the SCA folder the cell display is 
limited to CD20 and CD8. Changing the distance color assignment with slider tools in the measurement 
map will update the map. In the example shown, a B-cell at a distance greater than 50 microns from a 
CD8 T-cell is colored red. The measurement maps can also be used to display cell neighborhoods, 
which we will calculate in CytoMap.  

3.5 Batch analysis in QuPath 

To run spatial phenotyping using saved classifiers in a batch analysis:  
1) Ensure that for every image that needs to be analyzed there is an annotation that includes the 

region of interest on the image.  
2) In one image run the entire workflow (cell segmentation, classification, centroid distance) 
3) Navigate to the Workflow tab (right most tab) 

 
4) Click create script 
5) Copy and paste selectAnnotations() into the top line of the script 
6) In the script editor click Run → Run for project 
7) If results do not appear after running the batch load the results by keying CTRL+R on the 

keyboard 
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3.6  Export data in QuPath 

To export the cell table for cell neighborhood calculations, first save the experiment. Next, navigate to 
Measure → Export measurements. Select the images of interest to export and specify the output file 
location. Set the export type to ‘cells’ and set separator to ‘comma’. Click Populate to create a column 
list from the measurement table. Choose which columns to export. Export Centroid X, Centroid Y, 
Image, Class, and the Cell:Mean of each marker. Restricting the columns exported reduces calculation 
time and computational resources. Click export after columns are selected. 

4 CytoMap analysis 
4.1 Load data in CytoMap 

Launch CytoMap and click the File menu button. If multiple csv files were exported from QuPath 
choose to import multiple, otherwise load the cell table. Please note, the progress bar does not move in 
CytoMap. Wait for the next popup. Specify the X, Y, and Z columns when prompted. For the Z column 
specify “there is no Z, make a fake one”. An example is shown for the X column. 
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Click Annotate Clusters to import populations from QuPath. Select Class as the classification channel. 
Once the classes come into the Annotate Cells window select Save Annotations.  

 

 

4.2  Cellular Neighborhoods based on phenotype 

Define neighborhoods. Specify the neighborhood calculation mode (raster or cell centered). In this 
workflow we use a raster scan with 50 microns. Click OK when parameters are set, then close the 
‘Neighborhood Calculation Options’ window. 
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Specify spatial parameters to define spatial window for cell neighborhoods.  

 

 

Next, cluster neighborhoods into regions. In the example below, we are using cell types to cluster 
neighborhoods into regions. Use the default parameters unless you wish to do otherwise and click OK. 
Enter the name of this new model and click OK. In this example, the result was two neighborhoods.  
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Close the ‘Cluster RSN Neighborhoods’ window. Click region statistics to generate results regarding 
neighborhood composition. Select only phenotypes (second column) and use the default settings. Click 
OK to generate a heatmap of cell neighborhood composition.  Region heatmaps (main CytoMap menu 
button) can also be used to yield similar information.  

4.3 Cellular Neighborhood based on intensity 

For neighborhood calculations, we also have the option to cluster on markers rather than assigned cell 
phenotypes. Clustering the neighborhood on markers rather than phenotypes is an unsupervised 
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method of cell neighborhood determination and produces slightly different neighborhoods. To do this, 
click cluster neighborhoods into regions and select the Channel MFI of interest (in the fifth column). 
Click OK and enter the name of this new model. 
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4.4 Cell neighborhood interactions 

Close the ‘Region Statistics Options’ window. Click ‘Regions Interactions’ to calculate shared 
perimeters between cell neighborhoods. The thickness of the lines indicates how much of the perimeter 
is shared between two neighborhoods.  

 

Export cell table files to a specified folder by navigating to File → Export full data tables as csv. Deselect 
all channels except for X, Y, Image, and the model (neighborhood) calculation before clicking Export.  
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4.5 Uniform manifold approximation and projection of cell neighborhoods 

To calculate and display UMAP for cell neighborhoods navigate to Advanced → Dimensionality 
reduction on the main CytoMap page. Select the model used to calculate cell neighborhoods in the 
channel MFI column. Deselect all other channel MFI options. Select all phenotypes. Select UMAP as 
the algorithm (lower left) and Raster Scanned Neighborhoods as data type. Click OK and keep the 
default settings for UMAP when prompted. The UMAP calculation will display in real time.  

After the UMAP calculation is finished a UMAP plot will appear. Change the Channel-Axis (C-Axis) to 
the neighborhood model. This will color the UMAP according to cell neighborhood number. Colocation 
of neighborhoods in the XY coordinates of the UMAP indicates similarity.  
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4.6 Visualization of cell neighborhoods in QuPath 

In QuPath, run the neighborhood import script by dragging and dropping the script into QuPath. Click 
Run → run in the script editor. Click OK and select the folder containing the file(s) exported from 
CytoMap.  

 

The script will take time to complete.  

Go to measure and select measurement maps. Select the model used to describe cell neighborhoods 
from the list. Here we named the model composition_stnd_DB_RS_NN using a naming convention 
makes reference to what settings were used to generate neighborhoods in CytoMap.  Select the 
measurement map corresponding to the number of cell neighborhoods. Here we had five cell 
neighborhoods thus we selected CytoMap_colors_5. If greater than five neighborhoods were found use 
the colormap CytoMap_colors_6_or_more.  
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4.7 Clustering workflows 

Clusters calculated in CytoMap, R, or python can be imported into QuPath in the same manner as cell 
neighborhoods. In CytoMap, click cluster cells and select markers (Channel MFI) to use for clustering. 
We’ve set the normalization to standardize.  

  

 

In the example below, nine clusters were found.  
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A heatmap of cell composition can be generated by navigating to Extensions in CytoMap and selecting 
cell_heatmaps.m 

Export clusters from CytoMap and import clusters into QuPath using the same methods as were used for 
cell neighborhoods. (Note: In all cases data table columns must be exported in the order X, Y, Image, 
etc… this occurs automatically in CytoMap as long as the X, Y, and Image columns are selected for 
export. Files exported from R and python will need to be formatted appropriately.)  If preferred, clustering 
can be calculated first to guide supervised clustering. Within QuPath there are limited tools for cluster 
visualization and no tools for combining clusters at this time, thus supervised classification may provide 
a more straightforward route for initial phenotyping. Notably, specific phenotypes can be clustered in 
CytoMap to look for subpopulations of a phenotype identified with a supervised classifier. For more 
information on this workflow and other CytoMap and QuPath workflows we refer the reader to the 
CytoMap user guide, an image.sc forum tutorial on clusters, and an image.sc forum tutorial on cell 
neighborhoods.  

5 Video tutorial and support 
To request access to a video accompanying this document and for questions about this document 
please contact support@akoyabio.com 

https://gitlab.com/gernerlab/cytomap/-/wikis/Clustering-Cells
https://forum.image.sc/t/there-and-back-again-qupath-cytomap-cluster-analysis/43352
https://forum.image.sc/t/wont-you-be-my-neighbor-cytomap-for-multiplex-tissue-microenvironment-analysis/46260
https://forum.image.sc/t/wont-you-be-my-neighbor-cytomap-for-multiplex-tissue-microenvironment-analysis/46260
https://akoyabio-my.sharepoint.com/:v:/p/gcarlson/EbnAibf_AklCiWKqDKTnjFYBAT_gPLlKSZLSFR0yfcw9kQ?e=F1QGOi
mailto:support@akoyabio.com
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